Compartir


Con sistemas operativos con más de 15 años de desarrollo, cada vez resulta menos extraño que se hallen vulnerabilidades introducidas hace más de una década pero que no fueron descubiertas hasta hace poco. Eso es lo que le ha pasado hace poco a macOS, el sistema operativo de Apple para sus ordenadores Mac, al que se le ha encontrado una vulnerabilidad zero-day en el kernel que ha podido estar presente los últimos 15 años.

Al poco de comenzar el año 2018, un investigador en seguridad que utiliza el pseudónimo de Siguza publicó los detalles de una vulnerabilidad zero-day hallada en macOS. Según sus propias palabras, estima que podría estar presente en el sistema desde hace 15 años y ha publicado un código de prueba de concepto en GitHub. El fallo hallado en el sistema operativo de Apple permite la realización de una escalada de privilegios que podría permitir a un atacante obtener acceso como root en un sistema y ejecutar código malicioso. Sin embargo, algunas voces discrepan sobre el tiempo que lleva presente la vulnerabilidad y establecen su cantidad en 10 años.

La escalada de privilegios ha sido hallada en IOHIDFamily, una extensión del kernel de macOS creada para los dispositivos de interfaz humana, como las pantallas táctiles o los botones. La vulnerabilidad permite a un atacante instalar una shell con privilegios de administrador o ejecutar código arbitrario en el sistema. El exploit creado por Siguza, que ha sido bautizado como IOHIDeous, afecta a casi todas las versiones de macOS y OS X y provoca un fallo de lectura-escritura arbitraria en el kernel.

Además de lo explicado al final del párrafo anterior, IOHIDeous también inhabilita las características de seguridad Protección de Integridad del Sistema (SIP en sus siglas en inglés) e Integridad del Archivo Móvil de Apple (AMFI en sus siglas en inglés), dedicadas proteger del malware. El exploit no ha conseguido ser ejecutado con éxito en macOS High Sierra 10.13.2, pero sí en 10.13.1 y versiones anteriores del sistema operativo. Siguza cree que con modificaciones su exploit podría funcionar en la última versión de mantenimiento. Por otro lado, para que pueda funcionar se requiere que el usuario cierre y vuelva a iniciar sesión de alguna manera, ya sea cerrando la sesión explícitamente y volviéndola a iniciar, reiniciando la computadora o bien apagándola y encendiéndola de nuevo.

La vulnerabilidad no puede ser explotada de forma remota, lo que ha motivado al investigador a publicarla directamente en lugar de reportársela de forma privada a Apple, aparte que el programa de recompensas del gigante de Cupertino no cubre los fallos hallados en macOS.

Fuente: The Hacker News



Source link

Dejar una respuesta